Arduino 1.0

Arduino 1.0 has been released!

I installed it and started converting my code in order to make it compatible with this new Arduino’s version. I did that automatically thanks to some quick and dirty routines written in VB.NET for converting extensions and replacing “WProgram.h” by “Arduino.h”.

After that, some library codes would no longer compile, giving the following errors:

C:Documents and SettingsDidierMes documentsArduinolibrariesPlainGLCDPlainGLCD.cpp:1: error: stray '357' in program
C:Documents and SettingsDidierMes documentsArduinolibrariesPlainGLCDPlainGLCD.cpp:1: error: stray '273' in program
C:Documents and SettingsDidierMes documentsArduinolibrariesPlainGLCDPlainGLCD.cpp:1: error: stray '277' in program

These errors were due to the file format in use for the PlainGLCD.cpp file. If you are using Notepad++, check the actual file format (in my case, it was UTF8) and convert it to ANSI.

From now, unless specified, all my code shall be Arduino 1.0 compatible !

Leave a Reply

You must be logged in to post a comment.